Standard Updates

* indicates required